dynaperl

100% porentief rein

Artikel mit ‘dell’ getagged

Debian Etch auf Dell Power-Edge R300

Dienstag, 10. Februar 2009

Die Dell R300 Server haben auf dem Board zwei Broadcom NetXtreme Netzwerkkarten für die der Debian Etch Treiber tg3 nicht funktioniert. Die Quellen kann man sich bei Broadcom besorgen und folgendermaßen kompilieren.

apt-get install linux-headers-2.6.18-6-xen-amd64
unzip linux-3.92n.zip
tar xzf tg3-3.92n.tar.gz
cd tg3-3.92n
make KVER=2.6.18-6-xen-amd64
insmod ./tg3.ko
dmesg|tail

Eine weitere Besonderheit ist das die OMSA Tools  (Version 5.5) auf den R300 keinen Storage Controller finden. Für die Lösung ist das Tool lsiutil nötig welches man wie folgt kompiliert.

wget ftp://ftp.lsil.com/HostAdapterDrivers/linux/lsiutil/lsiutil.tar.gz tar xvfz lsiutil.tar.gz
cd lsiutil
rm lsiutil
make
cp lsiutil /usr/local/bin/

Nun kann man mit dem Tool die Laufwerke scannen und nach einem OMSA-Neustart findet OMSA die Laufwerke.

lsiutil -s; /etc/init.d/dataeng restart;

Damit das auch nach einem Neustart funktioniert habe ich mir lsiutil -s am Anfang mit in die /etc/init.d/dataeng gepackt.

Xen auf Dell PowerEdge 1950

Dienstag, 18. März 2008

Wer auf einem Dell PowerEdge 1950 unter Linux Xen als Virtualisierer verwenden will hat möglicherweise ein Problem mit der Xen Bridge. Standardmäßig richtet Xen eine Bridge (xenbr0) zwischen dem physikalischen Host Interface und den virtuellen Interfaceses der Gäste ein. Die Firmware der Broadcom NetXtreme II (BCM5708) Interfaces auf dem PE1950 Board hat allerdings einen Fehler. Nach dem Starten der Bridge ist kein Netzwerkverkehr mehr möglich. Alle Nic’s sind tot.

Der Dell Support weiß natürlich nichts von dem Problem. Hat auch keine Lösung parat. Und wenn man ihnen erzählt das man Debian verwendet liegt es natürlich daran. Da hilft auch kein Gold Support nicht. 🙂

http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=777

Gefunden habe ich die Lösung dann in einem Gmane Post. Das Problem ist wohl eine Management Funktion der Broadcom Interfaces die man allerdings eigentlich sowieso nicht braucht. Also schalten wir sie ab und sind zufrieden. Dazu laden wir uns von Dell ein Utilitie runter mit dem wir Einstellungen der NIC’s abfragen und ändern können.

  1. Nach dem Download entpacken wird das Archiv durch Doppelklick der EXE
  2. uxdiag.exe auf eine Bootfähige Diskette (ja Diskette) kopieren
  3. Diskette booten und dann für beide NIC’s MGM Firmware deaktivieren
uxdiag.exe -c 1 -mfw 0 
uxdiag.exe -c 2 -mfw 0

Bei mir gab es die Fehlermledung Register Test: Failed Reason: unknown
chip 5708B2.rdf. Die Funktion konnte aber trotzdem deaktiviert werden.

Update: ein halbes Jahr später gab es das Problem beim Nachfolgemodell 1950III immer noch.